aboutsummaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorLibravatar Alexander Foremny <aforemny@posteo.de>2024-05-28 22:04:34 +0200
committerLibravatar Alexander Foremny <aforemny@posteo.de>2024-05-28 22:04:34 +0200
commitec0ea18486ed2569808f2e511ecac52f812300b0 (patch)
treea03ef5a9272b8c9533c83f4e3a29a508e24cfeb1 /default.nix
init
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..060a4c7
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,25 @@
+{ pkgs ? import sources.nixpkgs { }
+, sources ? import ./nix/sources.nix
+}:
+let
+ haskellPackages = pkgs.haskellPackages.override {
+ overrides = self: super: {
+ acms = self.callCabal2nix "acms" ./. { };
+ astore = self.callCabal2nix "astore" sources.json2sql { };
+ autotypes = self.callCabal2nix "autotypes" ./autotypes { };
+ json2sql = self.callCabal2nix "json2sql" sources.json2sql { };
+ };
+ };
+in
+rec {
+ inherit (haskellPackages) acms;
+ shell = haskellPackages.shellFor {
+ packages = _: [ acms haskellPackages.autotypes ];
+ buildInputs = [
+ haskellPackages.cabal-install
+ haskellPackages.ormolu
+ ];
+ withHoogle = true;
+ withHaddock = true;
+ };
+}