aboutsummaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix26
1 files changed, 4 insertions, 22 deletions
diff --git a/default.nix b/default.nix
index eacf111..5fa2da4 100644
--- a/default.nix
+++ b/default.nix
@@ -1,30 +1,12 @@
-{ pkgs ? import sources.nixpkgs { }
+{ pkgs ? import sources.nixpkgs { overlays = [ (import ./pkgs { }) ]; }
, sources ? import ./nix/sources.nix
}:
let
- haskellPackages = pkgs.haskell.packages.ghc98.override {
- overrides = self: super: {
- astore = self.callCabal2nix "astore" sources.json2sql { };
- autotypes = self.callCabal2nix "autotypes" ./autotypes { };
- backend = self.callCabal2nix "backend" ./backend { };
- common = self.callCabal2nix "common" ./common { };
- frontend = self.callCabal2nix "frontend" ./frontend { };
- cli = self.callCabal2nix "cli" ./cli { };
- sh = pkgs.haskell.lib.dontCheck (self.callCabal2nix "sh" sources.sh { });
- websockets = pkgs.haskell.lib.doJailbreak super.websockets;
- };
- };
-
- jsHaskellPackages = pkgs.pkgsCross.ghcjs.haskell.packages.ghc98.override {
- overrides = self: super: {
- backend = self.callCabal2nix "backend" ./backend { };
- common = self.callCabal2nix "common" ./common { };
- frontend = self.callCabal2nix "frontend" ./frontend { };
- };
- };
+ haskellPackages = pkgs.haskell.packages.ghc98;
+ jsHaskellPackages = pkgs.pkgsCross.ghcjs.haskell.packages.ghc98;
in
rec {
- inherit (haskellPackages) backend;
+ inherit (haskellPackages) backend cli;
inherit (jsHaskellPackages) frontend;
shell = haskellPackages.shellFor {
packages = _: [