aboutsummaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index 32e9ff8..afea1a3 100644
--- a/default.nix
+++ b/default.nix
@@ -7,6 +7,7 @@ let
astore = self.callCabal2nix "astore" sources.json2sql { };
autotypes = self.callCabal2nix "autotypes" ./autotypes { };
backend = self.callCabal2nix "backend" ./backend { };
+ common = self.callCabal2nix "common" ./common { };
frontend = self.callCabal2nix "frontend" ./frontend { };
websockets = pkgs.haskell.lib.doJailbreak super.websockets;
};
@@ -14,6 +15,7 @@ let
jsHaskellPackages = pkgs.pkgsCross.ghcjs.haskell.packages.ghc98.override {
overrides = self: super: {
+ common = self.callCabal2nix "common" ./common { };
frontend = self.callCabal2nix "frontend" ./frontend { };
};
};
@@ -25,6 +27,7 @@ rec {
packages = _: [
haskellPackages.autotypes
haskellPackages.backend
+ haskellPackages.common
haskellPackages.frontend
];
buildInputs = [