aboutsummaryrefslogtreecommitdiffstats
path: root/pkgs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/default.nix')
-rw-r--r--pkgs/default.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/pkgs/default.nix b/pkgs/default.nix
new file mode 100644
index 0000000..7dce871
--- /dev/null
+++ b/pkgs/default.nix
@@ -0,0 +1,17 @@
+{ sources ? import ../nix/sources.nix }:
+(self: super:
+ let pkgs = self; in
+ {
+ haskell = super.haskell // {
+ packageOverrides = self: super: {
+ astore = self.callCabal2nix "astore" sources.json2sql { };
+ autotypes = self.callCabal2nix "autotypes" ../autotypes { };
+ backend = self.callCabal2nix "backend" ../backend { };
+ cli = self.callCabal2nix "cli" ../cli { };
+ common = self.callCabal2nix "common" ../common { };
+ frontend = self.callCabal2nix "frontend" ../frontend { };
+ sh = pkgs.haskell.lib.dontCheck (self.callCabal2nix "sh" sources.sh { });
+ websockets = pkgs.haskell.lib.doJailbreak super.websockets;
+ };
+ };
+ })