aboutsummaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorLibravatar Alexander Foremny <aforemny@posteo.de>2023-10-04 11:37:21 +0200
committerLibravatar Alexander Foremny <aforemny@posteo.de>2023-10-04 11:37:21 +0200
commitd12ee3bfa78699eab8f03d9b0d06ed2a9547ab37 (patch)
tree8a016c62cc0d3b4c18ccc00fa057eab02f4251e0 /default.nix
parentf72c9d076057729d98f12235c00482710d166cf8 (diff)
enable bash completion
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 722d91c..1708430 100644
--- a/default.nix
+++ b/default.nix
@@ -7,7 +7,13 @@ let
haskellPackages = pkgs.haskellPackages.override {
overrides = self: super: {
- anissue = super.callCabal2nix "anissue" ./. {};
+ anissue = (super.callCabal2nix "anissue" ./. { }).overrideAttrs (oldAttrs: {
+ postInstall = ''
+ exe=${oldAttrs.pname}
+ mkdir -p $out/share/bash-completion/completions
+ $out/bin/$exe --bash-completion-script $exe >$out/share/bash-completion/completions/$exe
+ '';
+ });
};
};