aboutsummaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix14
1 files changed, 12 insertions, 2 deletions
diff --git a/default.nix b/default.nix
index 06709df..59d560e 100644
--- a/default.nix
+++ b/default.nix
@@ -1,6 +1,16 @@
{ pkgs ? import <nixpkgs> {
overlays = [
- (import ./pkgs)
+ (self: super: {
+ tree-sitter = super.tree-sitter.overrideAttrs (oldAttrs: {
+ buildInputs = oldAttrs.buildInputs or [ ] ++ [
+ super.makeWrapper
+ ];
+ postInstall = oldAttrs.postInstall or "" + ''
+ wrapProgram $out/bin/tree-sitter \
+ --prefix LD_LIBRARY_PATH : "${super.tree-sitter.withPlugins (_: self.tree-sitter.allGrammars)}"
+ '';
+ });
+ })
(self: super: {
anissue = pkgs.writers.writeDashBin "anissue" ''
set -efu
@@ -22,7 +32,6 @@ let
dependencies = [
pkgs.coreutils
pkgs.git
- pkgs.tree-grepper
];
};
postInstall = ''
@@ -53,6 +62,7 @@ rec {
pkgs.anissue
pkgs.ghcid
pkgs.haskell-language-server
+ pkgs.tree-sitter
] ++ anissue.passthru.dependencies;
withHoogle = true;
withHaddock = true;