aboutsummaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index de120a5..ae21808 100644
--- a/default.nix
+++ b/default.nix
@@ -9,6 +9,7 @@ let
overrides = self: super: {
anissue = (super.callCabal2nix "anissue" ./. { }).overrideAttrs (oldAttrs: {
nativeBuildInputs = [ pkgs.installShellFiles ];
+ buildInputs = oldAttrs.buildInputs or [] ++ [ pkgs.makeWrapper ];
postInstall = ''
exe=${oldAttrs.pname}
@@ -16,6 +17,12 @@ let
--bash <($out/bin/$exe --bash-completion-script $exe) \
--fish <($out/bin/$exe --fish-completion-script $exe) \
--zsh <($out/bin/$exe --zsh-completion-script $exe)
+
+ wrapProgram $out/bin/$exe --prefix PATH : ${pkgs.lib.makeBinPath [
+ pkgs.git
+ pkgs.mdcat
+ pkgs.tree-grepper
+ ]}
'';
});
};