aboutsummaryrefslogtreecommitdiffstats
path: root/tests/nix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/nix.nix')
-rw-r--r--tests/nix.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/nix.nix b/tests/nix.nix
new file mode 100644
index 0000000..de2e7f3
--- /dev/null
+++ b/tests/nix.nix
@@ -0,0 +1,13 @@
+{ pkgs ? import <nixpkgs> {}, ... }:
+
+pkgs.mkShell {
+ # TODO add more dependencies
+ buildInputs = [
+ pkgs.tree-sitter
+ ];
+
+ /* TODO remove unnecessary content */
+ shellHook = ''
+ ls
+ ''
+}