summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/default.nix b/default.nix
index c0a928f..8e9b004 100644
--- a/default.nix
+++ b/default.nix
@@ -2,7 +2,6 @@
let
haskellPackages = pkgs.haskellPackages.override {
overrides = self: super: {
- atom-conduit = pkgs.haskell.lib.dontCheck (pkgs.haskell.lib.appendPatch super.atom-conduit ./atom-conduit.patch);
feed-nomath-org = self.callCabal2nix "feed-nomath-org" ./. { };
};
};
@@ -12,7 +11,6 @@ rec {
shell = haskellPackages.shellFor {
packages = _: [
feed-nomath-org
- haskellPackages.atom-conduit
];
buildInputs = [
haskellPackages.cabal2nix
@@ -21,5 +19,10 @@ rec {
];
withHoogle = true;
withHaddock = true;
+ shellHook = ''
+ REPOSITORIES=${pkgs.lib.concatStringsSep ":" [
+ "../feed-nomath-org"
+ ]}; export REPOSITORIES
+ '';
};
}