aboutsummaryrefslogtreecommitdiffstats
path: root/apps/cgit/appspec.nix
diff options
context:
space:
mode:
Diffstat (limited to 'apps/cgit/appspec.nix')
-rw-r--r--apps/cgit/appspec.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/apps/cgit/appspec.nix b/apps/cgit/appspec.nix
index 243f477..a7744d5 100644
--- a/apps/cgit/appspec.nix
+++ b/apps/cgit/appspec.nix
@@ -25,12 +25,12 @@
default = { };
};
users = lib.mkOption {
- type = lib.types.nullOr (lib.types.attrsOf (lib.types.submodule {
+ type = lib.types.attrsOf (lib.types.submodule {
options.publicKeyFile = lib.mkOption {
- type = lib.types.str;
+ type = lib.types.nullOr lib.types.str;
};
- }));
- default = null;
+ });
+ default = { };
};
};
}