aboutsummaryrefslogtreecommitdiffstats
path: root/pkgs/default.nix
diff options
context:
space:
mode:
authorLibravatar Alexander Foremny <aforemny@posteo.de>2025-02-19 21:03:19 +0100
committerLibravatar Alexander Foremny <aforemny@posteo.de>2025-02-19 21:03:21 +0100
commitcf20ad648a6654d2184b0b6f528d698a4fbc0b63 (patch)
treea340eeee92c317de1b3c7321b6959e747e9fdbaf /pkgs/default.nix
init
basic haskell-halogen project, `app/Main.hs` from Swordlash/haskell-halogen@0db1410e5bf2a383148fa067ae46a986a87c30c4
Diffstat (limited to 'pkgs/default.nix')
-rw-r--r--pkgs/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/pkgs/default.nix b/pkgs/default.nix
new file mode 100644
index 0000000..b46e6f8
--- /dev/null
+++ b/pkgs/default.nix
@@ -0,0 +1,23 @@
+{ lib
+, sources ? import ../nix/sources.nix
+, ...
+}:
+(self: super: {
+ haskell = super.haskell // {
+ packageOverrides = self: super: {
+ achat = (self.callCabal2nix "achat" ../. { }).overrideAttrs (_: {
+ postInstall = ''
+ mkdir -p $out/share
+ cp -a ./dist/build/achat/achat.jsexe $out/share
+ '';
+ });
+ haskell-halogen-core = lib.dontCheck (self.callCabal2nix "haskell-halogen-core" sources.haskell-halogen { });
+ protolude = lib.dontHaddock (
+ lib.appendConfigureFlags (lib.doJailbreak super.protolude) [
+ "--ghc-option=-fno-safe-haskell"
+ "--ghc-option=-fno-warn-x-partial"
+ ]);
+ clay = self.callHackage "clay" "0.15.0" { };
+ };
+ };
+})