aboutsummaryrefslogtreecommitdiffstats
path: root/autotypes/default.nix
diff options
context:
space:
mode:
authorLibravatar Alexander Foremny <aforemny@posteo.de>2024-05-28 22:04:34 +0200
committerLibravatar Alexander Foremny <aforemny@posteo.de>2024-05-28 22:04:34 +0200
commitec0ea18486ed2569808f2e511ecac52f812300b0 (patch)
treea03ef5a9272b8c9533c83f4e3a29a508e24cfeb1 /autotypes/default.nix
init
Diffstat (limited to 'autotypes/default.nix')
-rw-r--r--autotypes/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/autotypes/default.nix b/autotypes/default.nix
new file mode 100644
index 0000000..93962fe
--- /dev/null
+++ b/autotypes/default.nix
@@ -0,0 +1,16 @@
+{ mkDerivation, aeson, aeson-qq, base, bytestring, containers
+, filepath, lib, vector
+}:
+mkDerivation {
+ pname = "autotypes";
+ version = "0.1.0.0";
+ src = ./.;
+ isLibrary = true;
+ isExecutable = true;
+ libraryHaskellDepends = [
+ aeson aeson-qq base bytestring containers filepath vector
+ ];
+ executableHaskellDepends = [ aeson base bytestring filepath ];
+ license = "unknown";
+ mainProgram = "autotypes";
+}