aboutsummaryrefslogtreecommitdiffstats
path: root/pkgs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/default.nix')
-rw-r--r--pkgs/default.nix17
1 files changed, 13 insertions, 4 deletions
diff --git a/pkgs/default.nix b/pkgs/default.nix
index 660a462..cc883c0 100644
--- a/pkgs/default.nix
+++ b/pkgs/default.nix
@@ -1,18 +1,27 @@
{ sources ? import ../nix/sources.nix
}:
(self: super:
- let pkgs = self; in
+ let
+ pkgs = self;
+ haskellLib = pkgs.haskell.lib;
+ in
{
haskell = super.haskell // {
packageOverrides = pkgs.lib.composeManyExtensions [
super.haskell.packageOverrides
(self: super: {
acms = self.callCabal2nix "acms" ../acms { };
- astore = self.callCabal2nix "astore" sources.json2sql { };
+ astore = haskellLib.doJailbreak (self.callCabal2nix "astore" sources.json2sql { });
autotypes = self.callCabal2nix "autotypes" ../autotypes { };
frontend = self.callCabal2nix "frontend" ../frontend { };
- sh = pkgs.haskell.lib.dontCheck (self.callCabal2nix "sh" sources.sh { });
- websockets = pkgs.haskell.lib.doJailbreak super.websockets;
+ sh = haskellLib.dontCheck (self.callCabal2nix "sh" sources.sh { });
+ repline = haskellLib.doJailbreak super.repline;
+ uuid = haskellLib.doJailbreak super.uuid;
+ websockets = haskellLib.doJailbreak super.websockets;
+ hinotify = super.hinotify.overrideAttrs (_: {
+ version = "0.4.2";
+ src = builtins.fetchTarball "https://hackage.haskell.org/package/hinotify-0.4.2/hinotify-0.4.2.tar.gz";
+ });
})
];
};