aboutsummaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authorLibravatar Alexander Foremny <aforemny@posteo.de>2024-03-13 08:32:46 +0100
committerLibravatar Alexander Foremny <aforemny@posteo.de>2024-03-13 08:32:46 +0100
commit9671dd79163e654f61896ec4f61142a71c2f82c0 (patch)
tree3a37942ce7880d20d625b87360e19ec6c1e7ee70 /shell.nix
init
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..5214dde
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,21 @@
+{ pkgs ? import (import ./nix/sources.nix).nixpkgs { } }:
+let inherit (pkgs) lib; in
+pkgs.mkShell rec {
+ nativeBuildInputs = [
+ pkgs.cargo
+ pkgs.pkg-config
+ pkgs.rustc
+ ];
+ buildInputs = [
+ pkgs.alsa-lib
+ pkgs.libxkbcommon
+ pkgs.udev
+ pkgs.vulkan-loader
+ pkgs.wayland
+ pkgs.xorg.libX11
+ pkgs.xorg.libXcursor
+ pkgs.xorg.libXi
+ pkgs.xorg.libXrandr
+ ];
+ LD_LIBRARY_PATH = lib.makeLibraryPath buildInputs;
+}