aboutsummaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorLibravatar Fabian Kirchner <kirchner@posteo.de>2023-10-13 22:21:04 +0200
committerLibravatar Fabian Kirchner <kirchner@posteo.de>2023-10-13 22:21:04 +0200
commit73f3b070e7f710bea00ad83f9714fba90a75974b (patch)
tree531e5ba055b436a6cf9b9554c05b7c4785423b3f /default.nix
parent51663eab50cbc51a5786c0d55f21de62e9b15c0a (diff)
show commit hash where issue occurs first
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix19
1 files changed, 9 insertions, 10 deletions
diff --git a/default.nix b/default.nix
index bc7a9f4..f6bb4d1 100644
--- a/default.nix
+++ b/default.nix
@@ -7,17 +7,19 @@ let
haskellPackages = pkgs.haskellPackages.override {
overrides = self: super: {
- anissue = (super.callCabal2nix "anissue" ./. { }).overrideAttrs (oldAttrs: {
+ anissue = (super.callCabal2nix "anissue" ./. { }).overrideAttrs (oldAttrs: rec {
nativeBuildInputs = [ pkgs.installShellFiles ];
buildInputs = oldAttrs.buildInputs or [] ++ [ pkgs.makeWrapper ];
+ passthru.dependencies = [
+ pkgs.coreutils
+ pkgs.git
+ pkgs.mdcat
+ pkgs.tree-grepper
+ ];
postInstall = ''
exe=${oldAttrs.pname}
- wrapProgram $out/bin/$exe --prefix PATH : ${pkgs.lib.makeBinPath [
- pkgs.git
- pkgs.mdcat
- pkgs.tree-grepper
- ]}
+ wrapProgram $out/bin/$exe --prefix PATH : ${pkgs.lib.makeBinPath passthru.dependencies}
installShellCompletion --cmd $exe \
--bash <($out/bin/$exe --bash-completion-script $out/bin/.$exe-wrapped) \
@@ -38,11 +40,8 @@ rec {
haskellPackages.cabal-install
haskellPackages.ormolu
pkgs.ghcid
- pkgs.git
pkgs.haskell-language-server
- pkgs.mdcat
- pkgs.tree-grepper
- ];
+ ] ++ anissue.passthru.dependencies;
withHoogle = true;
shellHook = ''
HISTFILE=${pkgs.lib.escapeShellArg ./.}/.history; export HISTFILE