aboutsummaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorLibravatar Alexander Foremny <aforemny@posteo.de>2023-10-17 10:59:24 +0200
committerLibravatar Alexander Foremny <aforemny@posteo.de>2023-10-17 10:59:26 +0200
commitb24f614f0f6aa8363b12f007a44a5d4bc41ec739 (patch)
treed509efb7bc312af2596761e3c1c8bf4083725c20 /default.nix
parentda12170e694872fd91f81a27748eed07dc3f75cc (diff)
make filter type-aware
We interpret the following types: - ISO8601-formatted strings as dates, - integer-formatted strings as integers, - all other strings as strings. If the filter value matches a format, it is cast into the respective data type. For comparison-based filtering, the tag's value is then cast into the same data type and comparison is performed type-aware. If the tag's value is not castable, we consider it not matching.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/default.nix b/default.nix
index 8428c03..5bbe027 100644
--- a/default.nix
+++ b/default.nix
@@ -9,8 +9,9 @@ let
overrides = self: super: {
anissue = (super.callCabal2nix "anissue" ./. { }).overrideAttrs (oldAttrs: rec {
nativeBuildInputs = [ pkgs.installShellFiles ];
- buildInputs = oldAttrs.buildInputs or [] ++ [ pkgs.makeWrapper ];
- passthru = oldAttrs.passthru // { dependencies = [
+ buildInputs = oldAttrs.buildInputs or [ ] ++ [ pkgs.makeWrapper ];
+ passthru = oldAttrs.passthru // {
+ dependencies = [
pkgs.coreutils
pkgs.git
pkgs.mdcat
@@ -40,6 +41,7 @@ rec {
buildInputs = [
haskellPackages.cabal-install
haskellPackages.ormolu
+ haskellPackages.pointfree
pkgs.ghcid
pkgs.haskell-language-server
] ++ anissue.passthru.dependencies;