aboutsummaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorLibravatar Alexander Foremny <aforemny@posteo.de>2023-12-18 13:50:22 +0100
committerLibravatar Alexander Foremny <aforemny@posteo.de>2024-03-25 07:42:51 +0100
commitfc0afaaa273f5b5d3696df87d70d5347a13bb9ac (patch)
treea7e48842f71511f39a367e5dff84f41c02f3d859 /default.nix
parent812fcbadae72960d200286355c9aaecfbe350bf2 (diff)
feat: compute history top to bottom
Disables caching.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 4caf76a..0d16bcb 100644
--- a/default.nix
+++ b/default.nix
@@ -33,7 +33,12 @@
(self: super: {
anissue = pkgs.writers.writeDashBin "anissue" ''
set -efu
- exec cabal run anissue -- "$@"
+ cwd=$PWD
+ cd ${self.lib.escapeShellArg (toString ./.)}
+ cabal build anissue
+ anissue=$(find dist-newstyle -type f -executable -name anissue -exec realpath '{}' \; | head -1)
+ cd $cwd
+ exec $anissue "$@"
'';
})
];
@@ -48,6 +53,7 @@ let
./diff-parse.patch;
lingo = pkgs.haskell.lib.doJailbreak
(pkgs.haskell.lib.markUnbroken super.lingo);
+ sh = pkgs.haskell.lib.dontCheck (super.callCabal2nix "sh" (import ./nix/sources.nix).sh { });
anissue = (super.callCabal2nix "anissue" ./. ({
inherit (pkgs) tree-sitter;
} // pkgs.lib.filterAttrs (_: pkgs.lib.isDerivation)