aboutsummaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authorLibravatar Fabian Kirchner <kirchner@posteo.de>2023-10-02 14:41:18 +0200
committerLibravatar Fabian Kirchner <kirchner@posteo.de>2023-10-02 14:41:28 +0200
commite4a6ee2dbd9dfdd76bb77b647e13487fa2299d48 (patch)
treec5538db457cce1fe7d68ca8e472b700152917a27 /shell.nix
parent24700382f2e1f9b1dac1de3e8170294cf0c818d4 (diff)
add minimal haskell boilerplate
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix21
1 files changed, 1 insertions, 20 deletions
diff --git a/shell.nix b/shell.nix
index bff07ad..82fb296 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,20 +1 @@
-{ pkgs ? import <nixpkgs> {
- overlays = [ (import ./pkgs) ];
- }
-, ...
-}:
-
-pkgs.mkShell {
- buildInputs = [
- pkgs.coreutils
- pkgs.docopts
- pkgs.findutils
- pkgs.gawk
- pkgs.git
- pkgs.gnugrep
- pkgs.gnused
- pkgs.jq
- pkgs.ncurses
- pkgs.tree-grepper
- ];
-}
+(import ./default.nix {}).shell