aboutsummaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/default.nix b/default.nix
index 8428c03..5bbe027 100644
--- a/default.nix
+++ b/default.nix
@@ -9,8 +9,9 @@ let
overrides = self: super: {
anissue = (super.callCabal2nix "anissue" ./. { }).overrideAttrs (oldAttrs: rec {
nativeBuildInputs = [ pkgs.installShellFiles ];
- buildInputs = oldAttrs.buildInputs or [] ++ [ pkgs.makeWrapper ];
- passthru = oldAttrs.passthru // { dependencies = [
+ buildInputs = oldAttrs.buildInputs or [ ] ++ [ pkgs.makeWrapper ];
+ passthru = oldAttrs.passthru // {
+ dependencies = [
pkgs.coreutils
pkgs.git
pkgs.mdcat
@@ -40,6 +41,7 @@ rec {
buildInputs = [
haskellPackages.cabal-install
haskellPackages.ormolu
+ haskellPackages.pointfree
pkgs.ghcid
pkgs.haskell-language-server
] ++ anissue.passthru.dependencies;