aboutsummaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 722d91c..1708430 100644
--- a/default.nix
+++ b/default.nix
@@ -7,7 +7,13 @@ let
haskellPackages = pkgs.haskellPackages.override {
overrides = self: super: {
- anissue = super.callCabal2nix "anissue" ./. {};
+ anissue = (super.callCabal2nix "anissue" ./. { }).overrideAttrs (oldAttrs: {
+ postInstall = ''
+ exe=${oldAttrs.pname}
+ mkdir -p $out/share/bash-completion/completions
+ $out/bin/$exe --bash-completion-script $exe >$out/share/bash-completion/completions/$exe
+ '';
+ });
};
};