summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index a0d748b..f670ad4 100644
--- a/default.nix
+++ b/default.nix
@@ -2,7 +2,16 @@
let
haskellPackages = pkgs.haskellPackages.override {
overrides = self: super: {
- astatusbar = self.callCabal2nix "astatusbar" ./. { };
+ astatusbar = (self.callCabal2nix "astatusbar" ./. { }).overrideAttrs (oldAttrs: {
+ nativeBuildInputs = oldAttrs.nativeBuildInputs or [ ] ++ [ pkgs.installShellFiles ];
+ postInstall = oldAttrs.postInstall or "" + ''
+ exe=${oldAttrs.pname}
+ installShellCompletion --cmd $exe \
+ --bash <($out/bin/$exe --bash-completion-script $out/bin/$exe) \
+ --fish <($out/bin/$exe --fish-completion-script $out/bin/$exe) \
+ --zsh <($out/bin/$exe --zsh-completion-script $out/bin/$exe)
+ '';
+ });
sh = pkgs.haskell.lib.dontCheck (self.callCabal2nix "sh" (import ./nix/sources.nix).sh { });
statvfs = pkgs.haskell.lib.markUnbroken (super.statvfs.overrideAttrs (oldAtts: {
patches = [
@@ -58,6 +67,7 @@ rec {
packages = _: [ haskellPackages.astatusbar ];
buildInputs = [
pkgs.cabal-install
+ (pkgs.nerdfonts.override { fonts = [ "IosevkaTerm" ]; })
pkgs.niv
pkgs.ormolu
];