aboutsummaryrefslogtreecommitdiffstats
path: root/apps/authelia/appspec.nix
diff options
context:
space:
mode:
authorLibravatar Alexander Foremny <aforemny@posteo.de>2024-02-23 08:07:11 +0100
committerLibravatar Alexander Foremny <aforemny@posteo.de>2024-02-26 04:36:24 +0100
commit597ec76b7cb1527b1df215548a8f50bddccd8606 (patch)
tree9ea88686f3b15689e222a1d286a6726f6ce59ace /apps/authelia/appspec.nix
parentd2873fe0f6a117d7157c2a6f204a864f9edeb668 (diff)
apps/authelia: init
Diffstat (limited to 'apps/authelia/appspec.nix')
-rw-r--r--apps/authelia/appspec.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/apps/authelia/appspec.nix b/apps/authelia/appspec.nix
new file mode 100644
index 0000000..60e2695
--- /dev/null
+++ b/apps/authelia/appspec.nix
@@ -0,0 +1,33 @@
+{ appConfig, lib, ... }: {
+ name = "authelia";
+ endOfLife = null;
+ options = {
+ domain = lib.mkOption {
+ type = lib.types.str;
+ };
+ users = lib.mkOption {
+ type = lib.types.attrsOf (lib.types.submodule {
+ options.username = lib.mkOption {
+ type = lib.types.nullOr lib.types.str;
+ default = null;
+ };
+ options.passwordFile = lib.mkOption {
+ type = lib.types.nullOr lib.types.str;
+ default = null;
+ };
+ });
+ };
+ jwtSecret = lib.mkOption {
+ type = lib.types.str;
+ default = "system-secrets/${appConfig.appId}/jwtSecret";
+ };
+ storageEncryptionKey = lib.mkOption {
+ type = lib.types.str;
+ default = "system-secrets/${appConfig.appId}/storageEncryptionKey";
+ };
+ sessionSecret = lib.mkOption {
+ type = lib.types.str;
+ default = "system-secrets/${appConfig.appId}/sessionSecret";
+ };
+ };
+}