aboutsummaryrefslogtreecommitdiffstats
path: root/apps/cgit/appspec.nix
diff options
context:
space:
mode:
authorLibravatar Alexander Foremny <aforemny@posteo.de>2024-02-15 06:27:47 +0100
committerLibravatar Alexander Foremny <aforemny@posteo.de>2024-02-19 05:19:37 +0100
commitdb8cb61d4a13fa861440379f4788a6524d880467 (patch)
tree043f798a9ecb149285e06aaa3e46f2850d5c6a00 /apps/cgit/appspec.nix
parent59b9bf48851f85de8844d888de6c82dcfb4df5fa (diff)
init code.nomath.org
Diffstat (limited to 'apps/cgit/appspec.nix')
-rw-r--r--apps/cgit/appspec.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/apps/cgit/appspec.nix b/apps/cgit/appspec.nix
new file mode 100644
index 0000000..8ea967c
--- /dev/null
+++ b/apps/cgit/appspec.nix
@@ -0,0 +1,28 @@
+{ fysilib, lib, ... }: {
+ description = "cgit";
+ endOfLife = null;
+ options = {
+ domain = lib.mkOption {
+ description = "Domain of cgit instance";
+ type = fysilib.types.fqdn;
+ };
+ repositories = lib.mkOption {
+ type = fysilib.types.attrsOf (fysilib.types.submodule {
+ options = {
+ name = lib.mkOption {
+ default = null;
+ type = fysilib.types.pathComponent;
+ };
+ description = lib.mkOption {
+ default = null;
+ type = fysilib.types.nullOr fysilib.types.str;
+ };
+ };
+ });
+ };
+ settings = lib.mkOption {
+ type = lib.types.attrsOf (lib.types.oneOf [ lib.types.bool lib.types.int lib.types.str ]);
+ default = { };
+ };
+ };
+}