aboutsummaryrefslogtreecommitdiffstats
path: root/apps/static-users/appspec.nix
diff options
context:
space:
mode:
authorLibravatar Alexander Foremny <aforemny@posteo.de>2024-02-23 03:23:54 +0100
committerLibravatar Alexander Foremny <aforemny@posteo.de>2024-02-26 04:36:24 +0100
commit323973ecbb71b6186290a798af1c8a2c91299e18 (patch)
treef041e769aa593be6aab4e0f765fdd6c9b51164b7 /apps/static-users/appspec.nix
parent1057e0990509faa333843c7ab52536a95d50e7cc (diff)
apps/static-users: init
Diffstat (limited to 'apps/static-users/appspec.nix')
-rw-r--r--apps/static-users/appspec.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/apps/static-users/appspec.nix b/apps/static-users/appspec.nix
new file mode 100644
index 0000000..6ab5c7d
--- /dev/null
+++ b/apps/static-users/appspec.nix
@@ -0,0 +1,12 @@
+{ lib, ... }: {
+ description = "static-users";
+ endOfLife = null;
+ options.users = lib.mkOption {
+ type = lib.types.attrsOf (lib.types.submodule {
+ options.publicKeyFile = lib.mkOption {
+ type = lib.types.path;
+ };
+ });
+ default = { };
+ };
+}