aboutsummaryrefslogtreecommitdiffstats
path: root/apps/static-users/appspec.nix
diff options
context:
space:
mode:
authorLibravatar Alexander Foremny <aforemny@posteo.de>2024-05-07 09:43:19 +0200
committerLibravatar Alexander Foremny <aforemny@posteo.de>2024-05-07 09:43:51 +0200
commitc978457f3a591188b6273e93fdf397896322c9d5 (patch)
tree84b83e39c6a833cd7bedb8f4340d6a46abc9fada /apps/static-users/appspec.nix
parentfd001926dfab0d32ed41c6a6d0b36d5ad213696d (diff)
git: add kirchner's alternative ssh key
Diffstat (limited to 'apps/static-users/appspec.nix')
-rw-r--r--apps/static-users/appspec.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/apps/static-users/appspec.nix b/apps/static-users/appspec.nix
index cb55ea7..92ec8ba 100644
--- a/apps/static-users/appspec.nix
+++ b/apps/static-users/appspec.nix
@@ -7,9 +7,9 @@
type = lib.types.nullOr lib.types.str;
default = "system-secrets/${appConfig.appId}/${appConfig.users.${name}.username}.password";
};
- options.publicKeyFile = lib.mkOption {
- type = lib.types.nullOr lib.types.path;
- default = null;
+ options.publicKeyFiles = lib.mkOption {
+ type = lib.types.listOf lib.types.path;
+ default = [ ];
};
options.username = lib.mkOption {
type = lib.types.str;