aboutsummaryrefslogtreecommitdiffstats
path: root/terraform.nix
diff options
context:
space:
mode:
authorLibravatar Alexander Foremny <aforemny@posteo.de>2024-02-14 05:34:12 +0100
committerLibravatar Alexander Foremny <aforemny@posteo.de>2024-02-19 05:19:05 +0100
commit7e88fb2b26ba2c1a3aeaaaa21fe839f1a43bcc8b (patch)
treeab8dfb61657f88fe11215aaaac4d1b3f04775e20 /terraform.nix
init
Diffstat (limited to 'terraform.nix')
-rw-r--r--terraform.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/terraform.nix b/terraform.nix
new file mode 100644
index 0000000..70d4104
--- /dev/null
+++ b/terraform.nix
@@ -0,0 +1,16 @@
+let
+ inherit (import <fysiweb>) fysilib lib;
+in
+fysilib.terraform.eval (import <fysiweb/terraform.nix> {
+ resource = {
+ hcloud_server.system1 = {
+ name = "system1";
+ server_type = "cx11";
+ location = "nbg1";
+ image = "\${data.hcloud_image.base.id}";
+ ssh_keys = [
+ "fysiweb-cli"
+ ];
+ };
+ };
+})