aboutsummaryrefslogtreecommitdiffstats
path: root/apps/authelia/secrets.nix
diff options
context:
space:
mode:
Diffstat (limited to 'apps/authelia/secrets.nix')
-rw-r--r--apps/authelia/secrets.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/apps/authelia/secrets.nix b/apps/authelia/secrets.nix
new file mode 100644
index 0000000..1ad5f1a
--- /dev/null
+++ b/apps/authelia/secrets.nix
@@ -0,0 +1,5 @@
+{ appConfig, ... }: [
+ { type = "random-string"; path = appConfig.jwtSecret; }
+ { type = "random-string"; path = appConfig.sessionSecret; }
+ { type = "random-string"; path = appConfig.storageEncryptionKey; }
+]