aboutsummaryrefslogtreecommitdiffstats
path: root/apps/cgit/appspec.nix
diff options
context:
space:
mode:
Diffstat (limited to 'apps/cgit/appspec.nix')
-rw-r--r--apps/cgit/appspec.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/apps/cgit/appspec.nix b/apps/cgit/appspec.nix
index 8ea967c..243f477 100644
--- a/apps/cgit/appspec.nix
+++ b/apps/cgit/appspec.nix
@@ -24,5 +24,13 @@
type = lib.types.attrsOf (lib.types.oneOf [ lib.types.bool lib.types.int lib.types.str ]);
default = { };
};
+ users = lib.mkOption {
+ type = lib.types.nullOr (lib.types.attrsOf (lib.types.submodule {
+ options.publicKeyFile = lib.mkOption {
+ type = lib.types.str;
+ };
+ }));
+ default = null;
+ };
};
}