aboutsummaryrefslogtreecommitdiffstats
path: root/apps/feed-nomath-org/module.nix
diff options
context:
space:
mode:
Diffstat (limited to 'apps/feed-nomath-org/module.nix')
-rw-r--r--apps/feed-nomath-org/module.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/apps/feed-nomath-org/module.nix b/apps/feed-nomath-org/module.nix
new file mode 100644
index 0000000..e9c0937
--- /dev/null
+++ b/apps/feed-nomath-org/module.nix
@@ -0,0 +1,6 @@
+{ appConfig, lib, pkgs, ... }: {
+ systemd.services."feed-nomath-org".environment.PORT = "8080";
+ systemd.services."feed-nomath-org".environment.REPOSITORIES = lib.concatStringsSep ":" appConfig.repositories;
+ systemd.services."feed-nomath-org".script = "${pkgs.feed-nomath-org}/bin/feed-nomath-org";
+ systemd.services."feed-nomath-org".wantedBy = [ "multi-user.target" ];
+}