aboutsummaryrefslogtreecommitdiffstats
path: root/apps/static-users/appspec.nix
diff options
context:
space:
mode:
Diffstat (limited to 'apps/static-users/appspec.nix')
-rw-r--r--apps/static-users/appspec.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/apps/static-users/appspec.nix b/apps/static-users/appspec.nix
index cb55ea7..92ec8ba 100644
--- a/apps/static-users/appspec.nix
+++ b/apps/static-users/appspec.nix
@@ -7,9 +7,9 @@
type = lib.types.nullOr lib.types.str;
default = "system-secrets/${appConfig.appId}/${appConfig.users.${name}.username}.password";
};
- options.publicKeyFile = lib.mkOption {
- type = lib.types.nullOr lib.types.path;
- default = null;
+ options.publicKeyFiles = lib.mkOption {
+ type = lib.types.listOf lib.types.path;
+ default = [ ];
};
options.username = lib.mkOption {
type = lib.types.str;