aboutsummaryrefslogtreecommitdiffstats
path: root/apps/static-website/appspec.nix
diff options
context:
space:
mode:
Diffstat (limited to 'apps/static-website/appspec.nix')
-rw-r--r--apps/static-website/appspec.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/apps/static-website/appspec.nix b/apps/static-website/appspec.nix
new file mode 100644
index 0000000..c7e919e
--- /dev/null
+++ b/apps/static-website/appspec.nix
@@ -0,0 +1,14 @@
+{ fysilib, lib, ... }: {
+ description = "static website";
+ endOfLife = null;
+ options = {
+ domain = lib.mkOption {
+ description = "Domain of the website";
+ type = fysilib.types.fqdn;
+ };
+ root = lib.mkOption {
+ description = "Domain of the website";
+ type = fysilib.types.str;
+ };
+ };
+}