aboutsummaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authorLibravatar Alexander Foremny <aforemny@posteo.de>2024-02-13 05:10:58 +0100
committerLibravatar Alexander Foremny <aforemny@posteo.de>2024-02-16 04:38:13 +0100
commit25006ece6178292dfbaa485bc480b89ab9e8f059 (patch)
tree946ba7370781bdbf5bbfd654a2fca64d46581321 /shell.nix
init
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..3d46a11
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,9 @@
+{ pkgs ? import <nixpkgs> { } }:
+pkgs.mkShell {
+ buildInputs = [
+ (pkgs.writers.writeDashBin "develop" ''
+ set -efu
+ find src | entr -rs '( cd $(nix-build --no-out-link -A nomath-website) && python -m http.server )'
+ '')
+ ];
+}