summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorLibravatar Alexander Foremny <aforemny@posteo.de>2024-07-25 09:42:11 +0200
committerLibravatar Alexander Foremny <aforemny@posteo.de>2024-08-08 15:46:58 +0200
commit272b3ace747857729171780edae898819d211832 (patch)
tree5e791779a318521175104a7e9140dc186c4b3d54 /default.nix
init
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..3de5581
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,17 @@
+{ pkgs ? import (import ./nix/sources.nix).nixpkgs { } }: rec {
+ haskellPackages = pkgs.haskellPackages.override {
+ overrides = self: super: {
+ sensors = self.callCabal2nix "sensors" ./. { };
+ };
+ };
+ inherit (haskellPackages) sensors;
+ shell = haskellPackages.shellFor {
+ packages = _: [ sensors ];
+ buildInputs = [
+ haskellPackages.cabal-install
+ haskellPackages.ormolu
+ pkgs.niv
+ ];
+ withHoogle = true;
+ };
+}