aboutsummaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorLibravatar Alexander Foremny <aforemny@posteo.de>2025-02-19 21:03:19 +0100
committerLibravatar Alexander Foremny <aforemny@posteo.de>2025-02-19 21:03:21 +0100
commitcf20ad648a6654d2184b0b6f528d698a4fbc0b63 (patch)
treea340eeee92c317de1b3c7321b6959e747e9fdbaf /default.nix
init
basic haskell-halogen project, `app/Main.hs` from Swordlash/haskell-halogen@0db1410e5bf2a383148fa067ae46a986a87c30c4
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..9c7a8a1
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,27 @@
+{ pkgs ? import sources.nixpkgs {
+ overlays = [
+ (import ./pkgs { inherit (pkgs.haskell) lib; })
+ ];
+ }
+, sources ? import ./nix/sources.nix
+}:
+let
+ ghc = "ghc910";
+ haskellPackages = pkgs.pkgsCross.ghcjs.haskell.packages.${ghc};
+in
+rec {
+ inherit haskellPackages;
+ inherit (haskellPackages) achat;
+ shell = haskellPackages.shellFor {
+ packages = _: [
+ haskellPackages.achat
+ ];
+ nativeBuildInputs = [
+ pkgs.haskell.packages.${ghc}.cabal-install
+ pkgs.haskell.packages.${ghc}.ormolu
+ ];
+ shellHook = ''
+ export EM_CACHE="${toString ./.}/.emcache" # nixos/nixpkgs#282509
+ '';
+ };
+}