aboutsummaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..9c7a8a1
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,27 @@
+{ pkgs ? import sources.nixpkgs {
+ overlays = [
+ (import ./pkgs { inherit (pkgs.haskell) lib; })
+ ];
+ }
+, sources ? import ./nix/sources.nix
+}:
+let
+ ghc = "ghc910";
+ haskellPackages = pkgs.pkgsCross.ghcjs.haskell.packages.${ghc};
+in
+rec {
+ inherit haskellPackages;
+ inherit (haskellPackages) achat;
+ shell = haskellPackages.shellFor {
+ packages = _: [
+ haskellPackages.achat
+ ];
+ nativeBuildInputs = [
+ pkgs.haskell.packages.${ghc}.cabal-install
+ pkgs.haskell.packages.${ghc}.ormolu
+ ];
+ shellHook = ''
+ export EM_CACHE="${toString ./.}/.emcache" # nixos/nixpkgs#282509
+ '';
+ };
+}