aboutsummaryrefslogtreecommitdiffstats
path: root/agame.nix
diff options
context:
space:
mode:
authorLibravatar Alexander Foremny <aforemny@posteo.de>2024-03-15 06:15:41 +0100
committerLibravatar Alexander Foremny <aforemny@posteo.de>2024-03-15 08:47:41 +0100
commit1e162629da53373f0e2502014d42c7636412e67e (patch)
tree0fd311e28042ebee4f1f3df4cb97063c6bb4eafc /agame.nix
parentaa6901736da520d4608adfb74b8bc0a8a9e121a8 (diff)
chore: release
Diffstat (limited to 'agame.nix')
-rw-r--r--agame.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/agame.nix b/agame.nix
new file mode 100644
index 0000000..993d768
--- /dev/null
+++ b/agame.nix
@@ -0,0 +1,31 @@
+{ alsa-lib
+, lib
+, libxkbcommon
+, pkg-config
+, rustPlatform
+, udev
+, vulkan-loader
+, wayland
+, xorg
+}:
+rustPlatform.buildRustPackage rec {
+ name = "agame";
+ src = ./.;
+ cargoLock.lockFile = ./Cargo.lock;
+ buildNoDefaultFeatures = true;
+ nativeBuildInputs = [
+ pkg-config
+ ];
+ buildInputs = [
+ alsa-lib
+ libxkbcommon
+ udev
+ vulkan-loader
+ wayland
+ xorg.libX11
+ xorg.libXcursor
+ xorg.libXi
+ xorg.libXrandr
+ ];
+ doCheck = false;
+}