aboutsummaryrefslogtreecommitdiffstats
path: root/agame.nix
diff options
context:
space:
mode:
Diffstat (limited to 'agame.nix')
-rw-r--r--agame.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/agame.nix b/agame.nix
new file mode 100644
index 0000000..993d768
--- /dev/null
+++ b/agame.nix
@@ -0,0 +1,31 @@
+{ alsa-lib
+, lib
+, libxkbcommon
+, pkg-config
+, rustPlatform
+, udev
+, vulkan-loader
+, wayland
+, xorg
+}:
+rustPlatform.buildRustPackage rec {
+ name = "agame";
+ src = ./.;
+ cargoLock.lockFile = ./Cargo.lock;
+ buildNoDefaultFeatures = true;
+ nativeBuildInputs = [
+ pkg-config
+ ];
+ buildInputs = [
+ alsa-lib
+ libxkbcommon
+ udev
+ vulkan-loader
+ wayland
+ xorg.libX11
+ xorg.libXcursor
+ xorg.libXi
+ xorg.libXrandr
+ ];
+ doCheck = false;
+}