aboutsummaryrefslogtreecommitdiffstats
path: root/apps/static-users/appspec.nix
diff options
context:
space:
mode:
authorLibravatar Alexander Foremny <aforemny@posteo.de>2024-02-23 08:07:11 +0100
committerLibravatar Alexander Foremny <aforemny@posteo.de>2024-02-26 04:36:24 +0100
commit597ec76b7cb1527b1df215548a8f50bddccd8606 (patch)
tree9ea88686f3b15689e222a1d286a6726f6ce59ace /apps/static-users/appspec.nix
parentd2873fe0f6a117d7157c2a6f204a864f9edeb668 (diff)
apps/authelia: init
Diffstat (limited to 'apps/static-users/appspec.nix')
-rw-r--r--apps/static-users/appspec.nix17
1 files changed, 13 insertions, 4 deletions
diff --git a/apps/static-users/appspec.nix b/apps/static-users/appspec.nix
index 6ab5c7d..cb55ea7 100644
--- a/apps/static-users/appspec.nix
+++ b/apps/static-users/appspec.nix
@@ -1,12 +1,21 @@
-{ lib, ... }: {
+{ appConfig, lib, ... }: {
description = "static-users";
endOfLife = null;
options.users = lib.mkOption {
- type = lib.types.attrsOf (lib.types.submodule {
+ type = lib.types.attrsOf (lib.types.submodule ({ name, ... }: {
+ options.passwordFile = lib.mkOption {
+ type = lib.types.nullOr lib.types.str;
+ default = "system-secrets/${appConfig.appId}/${appConfig.users.${name}.username}.password";
+ };
options.publicKeyFile = lib.mkOption {
- type = lib.types.path;
+ type = lib.types.nullOr lib.types.path;
+ default = null;
+ };
+ options.username = lib.mkOption {
+ type = lib.types.str;
+ default = name;
};
- });
+ }));
default = { };
};
}