aboutsummaryrefslogtreecommitdiffstats
path: root/apps/static-users/appspec.nix
diff options
context:
space:
mode:
Diffstat (limited to 'apps/static-users/appspec.nix')
-rw-r--r--apps/static-users/appspec.nix17
1 files changed, 13 insertions, 4 deletions
diff --git a/apps/static-users/appspec.nix b/apps/static-users/appspec.nix
index 6ab5c7d..cb55ea7 100644
--- a/apps/static-users/appspec.nix
+++ b/apps/static-users/appspec.nix
@@ -1,12 +1,21 @@
-{ lib, ... }: {
+{ appConfig, lib, ... }: {
description = "static-users";
endOfLife = null;
options.users = lib.mkOption {
- type = lib.types.attrsOf (lib.types.submodule {
+ type = lib.types.attrsOf (lib.types.submodule ({ name, ... }: {
+ options.passwordFile = lib.mkOption {
+ type = lib.types.nullOr lib.types.str;
+ default = "system-secrets/${appConfig.appId}/${appConfig.users.${name}.username}.password";
+ };
options.publicKeyFile = lib.mkOption {
- type = lib.types.path;
+ type = lib.types.nullOr lib.types.path;
+ default = null;
+ };
+ options.username = lib.mkOption {
+ type = lib.types.str;
+ default = name;
};
- });
+ }));
default = { };
};
}